Welcome, Guest. Please login or register.
Did you miss your activation email?

Username: Password:


Pages: [1] 2 ... 5   Go Down
  Subject Started by Replies Views Last post
Running DinoMITE on win 8?? Alexandri 0 895 Last post January 05, 2016, 07:03:11 AM
by Alexandri
About upgrading an Ugobe Pleo Icewolf 19 3802 Last post January 04, 2016, 08:02:37 AM
by Alexandri
Problems with my Ugobe honi 7 1355 Last post October 19, 2015, 01:10:33 PM
by honi
Pleo Battery Question - original Pleo vs. 2009 Pleo fleuter10 1 1045 Last post August 20, 2015, 08:07:30 PM
by Crewella
Not starting: reporting zero battery and crazy temperature arpruss 2 829 Last post May 10, 2015, 05:36:04 PM
by kat
No More Egg Batteries? Torterenek 16 2591 Last post April 24, 2015, 01:36:30 PM
by roschler
pleo problem 123445 1 755 Last post April 22, 2015, 04:56:41 PM
by kat
Ugobe Pleos 'reset to packing position' will not work... taoworm23 3 992 Last post April 03, 2015, 04:37:41 PM
by taoworm23
desperately need a ugobe battery irbyma7297 4 1006 Last post December 10, 2014, 01:28:17 PM
by InmemoryofRomeo
pleo not working irbyma7297 6 1706 Last post December 05, 2014, 05:17:39 PM
by kat
do 2009 pleo batteries work on the original? irbyma7297 2 960 Last post December 03, 2014, 01:23:47 PM
by irbyma7297
My Ugobe Pleo "Ozzy" Jett 13 1544 Last post December 01, 2014, 01:33:22 PM
by HuggieZ
Old Ugobe Battery? Skygryph 5 932 Last post November 30, 2014, 02:09:55 PM
by Skygryph
Problems with Pleo 0214671 13 3244 Last post November 23, 2014, 01:36:23 AM
by InmemoryofRomeo
Ugobe Pleo seems to restart himself over and over « 1 2 3 » Icewolf 52 5363 Last post November 21, 2014, 05:05:31 PM
by kat
Deep troubleshooting Battery / Thermistor issues - SOLVED meuon 5 1727 Last post November 17, 2014, 10:38:13 PM
by InmemoryofRomeo
Pleo with no life T_T « 1 2 3 » secreteyez 57 6586 Last post September 12, 2014, 04:41:02 PM
by secreteyez
Ugobe Pleo Skincare Treatment « 1 2 3 » Crewella 65 13936 Last post July 18, 2014, 04:56:53 PM
by InmemoryofRomeo
Downloading Life os on Ugobe pleo DinoBot 16 6615 Last post May 11, 2014, 04:42:30 PM
by InmemoryofRomeo
Customizing a pleo ^o^ Punkbird 1 857 Last post May 10, 2014, 05:27:52 AM
by InmemoryofRomeo
Leg touch sensor degers 6 921 Last post April 26, 2014, 05:48:22 AM
by Crewella
OS 2.0.1 question? camcam8910 7 1764 Last post April 23, 2014, 08:06:24 AM
by camcam8910
OLDER PLEO FIRMWARE ABB 2 1915 Last post March 08, 2014, 05:07:40 PM
by Crewella
problem with pleo or battery? cchimp123 5 1261 Last post February 11, 2014, 06:10:25 PM
by InmemoryofRomeo
how to reset original pleo? irbyma7297 17 10540 Last post December 27, 2013, 02:12:32 PM
by InmemoryofRomeo
Old Pleo 2008 won’t work. Need Technical assistance. Eamo600 4 1151 Last post March 25, 2013, 06:37:41 PM
by Crewella
Lethargic? riabobia 14 1999 Last post February 25, 2013, 08:09:43 AM
by zetathix
Ugobe pleo 2.0.1 update trouble Torterenek 16 3167 Last post February 19, 2013, 08:06:02 PM
by Torterenek
Usb drivers Pleo Ugobe Dénman 1 2986 Last post February 05, 2013, 11:29:06 AM
by mlbelanger
My Pleo is updated but it doesn't work! PleoEng 15 2758 Last post January 31, 2013, 12:08:32 PM
by PleoEng
Dead Pleo? InkyMortar 7 1587 Last post January 08, 2013, 07:03:14 PM
by irbyma7297
Pleo only lasts about 10 mins and can't walk Robbie 5 1674 Last post January 02, 2013, 05:58:38 PM
by Robbie
My daughter got a (used) Pleo for Christmas and it's not working. Please Help! shellyhec 3 1140 Last post December 25, 2012, 05:12:18 PM
by kat
please can anyone help?? ive just downgraded my pleo & now it doesnt work :( jonnyb80 3 1136 Last post December 25, 2012, 08:00:25 AM
by kat
My pleo rbs are slow to respond to food!!!! nicholasljy123 2 1058 Last post December 24, 2012, 07:38:07 AM
by Talon
need help with pleo attisaur 7 1826 Last post December 23, 2012, 07:54:40 PM
by nicholasljy123
OS2 tricks - IMR's Videos Crewella 4 3155 Last post December 18, 2012, 07:56:37 PM
by irbyma7297
Help to update my ugobe pleo Yehuda 8 2213 Last post December 17, 2012, 12:37:37 PM
by Crewella
Eliot's Issues... gucci_boi7782 12 2502 Last post December 17, 2012, 09:52:55 AM
by InmemoryofRomeo
Bringing a Pleo back to life after 2 years srbfl 7 1687 Last post December 15, 2012, 08:13:18 AM
by Crewella
Old Pleo issues Latefa 13 2145 Last post December 06, 2012, 03:21:14 PM
by kat
CHARGER PROBLEMS!!! irbyma7297 3 1116 Last post December 04, 2012, 11:05:53 PM
by kat
Loud motor noise coming from Pleo's neck *Update* It's her knee :( Fleur 13 3711 Last post December 04, 2012, 09:22:39 PM
by RedwoodsMama
New owner - battery issues Kleines 6 1927 Last post December 01, 2012, 10:40:53 AM
by RedwoodsMama
Ugobe stuck in "huh?" loop on boot up pirpintine 5 2511 Last post November 25, 2012, 04:32:03 PM
by kat
My Pleo is Dead Dénman 8 1833 Last post November 23, 2012, 04:44:44 PM
by kat
speaker problems in ugobe? irbyma7297 4 1109 Last post November 17, 2012, 11:08:47 AM
by RedwoodsMama
Egg charger with USB and Pleo Number Kiromanta 8 1896 Last post October 10, 2012, 09:07:44 AM
by irbyma7297
original pleo. irbyma7297 8 2818 Last post October 09, 2012, 04:55:21 PM
by irbyma7297
Not quite an owner- Brand new Pleo.. Sluggish? CrazeUK 10 2065 Last post October 05, 2012, 03:51:42 PM
by kat
Pages: [1] 2 ... 5   Go Up

 

  • Normal Topic
  • Hot Topic (More than 25 replies)
  • Very Hot Topic (More than 50 replies)
  • Locked Topic
  • Sticky Topic
  • Poll