Welcome, Guest. Please login or register.
Did you miss your activation email?

Username: Password:




Pages: 1 ... 3 [4]   Go Down

Author Topic: Common battery problems and possible solutions! Green Ugobe batteries only!  (Read 33579 times)

Mini Me Pleo

  • Outstanding in the herd
  • **** Posts: 57
  • 00 Female
  • Pleo(s): Luke
  • Greetings from the USA!!!
    • Professor
    • Bugs_Bunny
    • Kermit
    • Snoopy
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #75 on: September 23, 2013, 07:36:24 PM »

i have had the pleo for 3-4 years and he came with two battterys by mistake but i kept both but i lost one :hissyfit: :head-wall:

he has other skin problems with him but i wouldn't think it would effect it 
« Last Edit: September 25, 2013, 01:15:59 PM by Mini Me Pleo »
Logged
~Mini Me Pleo

RedwoodsMama

  • Pleo Grand Master, 4th epoch
  • **** Posts: 4869
  • us Female
  • Pleo(s): Nova, Major Tom, Argyle the blind Pleo, Baby Ruth, Chester, and 22 more Pleos
  • : 2013 winner2010 winnerTomato Harvest Festivals
    • Mary_Ann
    • Silvester
    • none
    • Flying_Ace
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #76 on: September 23, 2013, 08:13:18 PM »

Did he use to work, with the batteries that is? If so, then I would think it is safe to say the batteries no longer work. The only way to know for sure is to try and clean them and see if they will charge. If after four hours and charged and not running in your Pleo, then I would think it is safe to say the battery is dead, but try the other suggestions first, cleaning the battery terminals, etc. If the battery is indeed dead, I sell the Ucube Egg charger and Li Polymer battery for Ugobes. I have a shop here on the forum and you can contact me to see the cost if you want one. Good luck.  RWM  :cat-hug:
Logged
Animals are SOUL Too, Be kind to all those who live on this planet with us.

Mini Me Pleo

  • Outstanding in the herd
  • **** Posts: 57
  • 00 Female
  • Pleo(s): Luke
  • Greetings from the USA!!!
    • Professor
    • Bugs_Bunny
    • Kermit
    • Snoopy
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #77 on: September 24, 2013, 08:30:15 PM »

Thanks so much I think you might have just saved my poor little pleo!  :rofl: :cool:


Logged
~Mini Me Pleo

Mini Me Pleo

  • Outstanding in the herd
  • **** Posts: 57
  • 00 Female
  • Pleo(s): Luke
  • Greetings from the USA!!!
    • Professor
    • Bugs_Bunny
    • Kermit
    • Snoopy
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #78 on: September 24, 2013, 08:35:12 PM »

and yes the battery used to work fine but now its just bad
Logged
~Mini Me Pleo

RedwoodsMama

  • Pleo Grand Master, 4th epoch
  • **** Posts: 4869
  • us Female
  • Pleo(s): Nova, Major Tom, Argyle the blind Pleo, Baby Ruth, Chester, and 22 more Pleos
  • : 2013 winner2010 winnerTomato Harvest Festivals
    • Mary_Ann
    • Silvester
    • none
    • Flying_Ace
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #79 on: September 27, 2013, 12:32:09 AM »

I wasn't sure from reading your answers, if you were able to fix your battery or not...? Did you try cleaning the battery terminals, with a small amount of rubbing alcohol on a q tip....., did it start working... or did you just decide it does not work at all, and at some point you need a new battery? I am confused at to which solution you came to... ???              RWM  :cat-hug:
Logged
Animals are SOUL Too, Be kind to all those who live on this planet with us.

Pleonewbie

  • Hatchling
  • Posts: 1
  • Female
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #80 on: December 25, 2013, 06:38:36 PM »

Just got my son Pleo for Christmas and now the battery is nor charging! It is inserted correctly into the charger, the charger is plugged in correctly into the electrical outlet, but the light keeps flashing green and it is NOT charging... I have read here that there could be problems if the battery has been on the shelf too long. What to do??? Advice is highly appreciated; my son is so disappointed! Thank you!
Logged

kat

  • Global Moderator
  • Pleo Grand Master, 2nd epoch
  • * Posts: 3924
  • au Female
  • Pleo(s): Kermit (Pink RB), Norbit (Green RB), Pickle(nude RB), Gumble, Minyon and Frankie
  • : 2013 winnerTomato Harvest Festivals
    • Marvin_Martian
    • Kermit
    • Flying_Ace
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #81 on: December 25, 2013, 07:41:23 PM »

Try cleaning the silver contacts on the bottom of the battery and the charger with a soft cloth.  give them a good rub and see if that makes a difference
Logged

BigRed

  • Hatchling
  • Posts: 1
  • gb Male

does anyone know where I could get the egg style batteries and chargers from in the uk please? or somewhere that will ship them to the uk?
I bought a ugobe pleo for Christmas for my girlfriend and it comes with the original battery/charger, the pleo will move for about 10 seconds then just freeze so think the better batteries would work ok then? just cant seem to find any in the uk or anywhere that ship them?
thanks alot :)
Joe
Logged

kat

  • Global Moderator
  • Pleo Grand Master, 2nd epoch
  • * Posts: 3924
  • au Female
  • Pleo(s): Kermit (Pink RB), Norbit (Green RB), Pickle(nude RB), Gumble, Minyon and Frankie
  • : 2013 winnerTomato Harvest Festivals
    • Marvin_Martian
    • Kermit
    • Flying_Ace

Sadly the egg chargers and batteries seem to have disappeared from the market at the moment.  Not sure if the company that was making them has stopped and now they have run out of stock.  Even our supplier here on the forums can't get them :(  I think at the moment your best bet is to buy a battery from pleoworld for the 2009 version pleo.  Or keep an eye out on ebay as sometimes you will find a battery advertised from a seller in China that is for both pleo and pleo rb - it costs around $100 or so and the seller claims that it will run in pleo for 2 to 4 hours.  It really only runs for 2 hours (I have one :)  )  but it does work in both the ugobe pleos and in pleo rb's. 

Fingers crossed that you manage to find a battery.
Logged

spite

  • Guest
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #84 on: December 26, 2014, 07:33:20 AM »

Hi, I'm new here, and just got my son a Ugobe Pleo (from ebay) for Christmas yesterday.
We got the Pleo a couple months ago, and I charged the battery and played with Pleo for a few seconds to make sure he worked.  Then I tucked him away until Christmas - which I have now learned was not the best idea!  I cannot get my battery light to turn green at all, and I haven't seen anyone else on the forums (or google) with this issue.

I put the battery on the charger and get a bright red light, but after 15-20 minutes the light completely turns off.  I have repositioned the battery soo many times, and it makes no difference.  The only thing that seems weird is I can push the battery down a little - like it's not 100% firmly on there?  The battery never gets warm, and even after trying to reseat the battery over and over yesterday, I got zero power from Pleo when the battery was inserted.
The only other thing is if  I push the battery really firmly onto the charger, I get a rapidly flashing green light.  I am assuming this means the battery isn't placed correctly?  I am so frustrated, and my son has been dying for Pleo and can't even enjoy him now :(
Logged

Crewella

  • Global Moderator
  • Pleo Grand Master RB
  • * Posts: 5671
  • gb Female
  • Pleo(s): Iggy, Budge, Moschops, Monty, Emmy. Belle, Zillah, Tribble
  • : 2010 winnerTomat Harvest Festivals
    • Ginger
    • Pepe_Le_Pew
    • Animal
    • Flying_Ace
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #85 on: December 26, 2014, 08:49:33 AM »

That's a weird one ..... I guess it might be a charger issue - it could be worth trying to plug the charger in another socket?  Double check that you have the corect adapter cord?
Logged

Talon

  • Cretaceous pleo master
  • * Posts: 2640
  • us Female
  • Pleo(s): Ryu and Cato (Pleo RBs), Eugobe and Madam Bayou Bleu Le Chalet, (Ugobe Pleos)
    • Lucy
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #86 on: December 26, 2014, 10:04:09 AM »

That is an odd issue. It could be your charger or its cord. Just for the sake of process of elimination, I would try cleaning the contacts on all terminals- inside pleo's belly, the charging terminals, and the contacts on the battery with a cue tip dipped in a little rubbing alcohol. Also make sure all the little contacts in your charger are touching the battery. Sometimes when you set the battery on, those little spring-loaded terminals turn slightly. Good luck with getting your son's Ugobe up and running!
Talon
Logged

spite

  • Guest
Re: Common battery problems and possible solutions! Green Ugobe batteries only!
« Reply #87 on: December 28, 2014, 04:11:12 PM »

I cleaned the terminals with alcohol & it fixed everything!!!  ;D  Thanks so much.  Now we are playing with Pleo (my son didn't want to get too creative with his name, haha) regularly.

I just wish we could get an extra battery easily - I looked into ordering a spare from pleoworld and the shipping alone was almost $50 US.   :'(
Logged

FROOBXD

  • Hatchling
  • Posts: 1
  • nl Male
  • Pleo(s): Herman
Re: Common battery problems and possible solutions!
« Reply #88 on: April 27, 2015, 03:17:39 AM »

Keep trying it Gucci, perhaps you can revive it after all :)
Thanks, my Ugobe Pleo 'Herman' was not turned on for a while until yesterday and i had the same battery problems.
I read this thread and i reconditioned the original Pleo battery, It turned on for 2 seconds but then it stopped. So i guess i have to reseet it longer.
I hope that that will work.
Logged

coopersoriginal

  • Hatchling
  • Posts: 1
  • gb Female
  • Pleo(s): pleo

Hi.can anyone tell me where to get a new battery in the uk for my original 2006 pleo? All the links I have seen are no longer available. My pleo is stuck saying huh and slowly twitching. I am trying to recondition the battery but not getting anywhere.  A friend tried a battery he has in our pleo and pleo worked well so looks like it is all battery related.hope someone can help.thanks.
Logged

HuggieZ

  • Pleo lightbringer
  • * Posts: 339
  • nl Female
  • Pleo(s): Pepper and Angel
    • none
    • Tweety_Bird
    • Miss_Piggy
    • Snoopy

At Pleoworld they sell the original batteries for the Ugobe.
Logged

dabanse

  • Hatchling
  • Posts: 1
  • us Female
  • Pleo(s): NONAME

Hi,

I have a problem with my Ugobe Pleo first generation battery. Whenever I try to charge, it flashes green and I have repeatedly placed it in and out of the charger and made sure it snapped in properly. Is this because it was sitting unused for two years? My poor Pleo is frozen is position, has his legs all sprawled out with his head down in a sleeping position! I really don't want to keep this either way, and when it was last used it worked great. At this point if I cannot get a charge I am looking to sell, my daughter does not seem interested anymore, she wasnt very interested when we first purchased. It shows no damage so any suggestion would be appreciated! Thanks!

Debbi
Logged

kat

  • Global Moderator
  • Pleo Grand Master, 2nd epoch
  • * Posts: 3924
  • au Female
  • Pleo(s): Kermit (Pink RB), Norbit (Green RB), Pickle(nude RB), Gumble, Minyon and Frankie
  • : 2013 winnerTomato Harvest Festivals
    • Marvin_Martian
    • Kermit
    • Flying_Ace

Sounds like that battery is dead.  The green ugobe batteries are all pretty much dead now and they don't do well left sitting for long periods of time with no use.  You can get a replacement battery from pleoworld  - they do batteries for their 2009 pleo which work with the ugobe pleos.  A new battery would solve your problem.

As a last chance for your old battery try cleaning the contacts on the batery and charger.  Use a cuetip or a soft cloth slightly damp and rub over the silver parts on both the battery and the charger.  This may help as two years build up of dust and grime from sitting could be stopping the battery from making proper contact with the charger.
« Last Edit: October 07, 2015, 05:13:50 PM by kat »
Logged
Pages: 1 ... 3 [4]   Go Up