Welcome, Guest. Please login or register.
Did you miss your activation email?

Username: Password:

Pages: [1]   Go Down

Author Topic: Pleo Battery Not Charging?  (Read 1935 times)


  • Coffee leaf addict
  • *** Posts: 54
  • Male
Pleo Battery Not Charging?
« on: November 27, 2016, 05:19:22 AM »

Hi all,
Recently I decided to charge my Pleo RB up (after a good 2 years of inaction and storage).
However, upon attaching the battery to the cradle, with 2 confirmed clicks to ensure a secure connection, the battery cradle light still keeps flashing red. I have tried to connect the battery to the cradle several times and even cleaned the connections with isopropyl alcohol thoroughly. The battery cradle indicator still flashes red incessantly.
Has anyone encountered a similar problem? Is the battery simply dead after a few years of not charging?

Thank you in advance!

Nicholas Jun Yi


  • Cretaceous pleo master
  • * Posts: 2656
  • us Female
  • Pleo(s): Ryu and Cato (Pleo RBs), Eugobe and Madam Bayou Bleu Le Chalet, (Ugobe Pleos)
    • Lucy
Re: Pleo Battery Not Charging?
« Reply #1 on: November 27, 2016, 05:37:27 AM »

Nice to see you back! Yes. a completely dead battery would be my guess too unfortunately. I'm not sure if our classic reseating process that worked for the old Ugobe batteries would be of any use to you. You might just have to purchase a new battery through Pleoworld or else look on EBay or somewhere for a working battery. Good luck and I hope your Pleo revives with no further issues other than its battery.


  • Pleo mentor
  • * Posts: 834
  • us Female
  • Pleo(s): A whole herd of robotic dinosuars!
Re: Pleo Battery Not Charging?
« Reply #2 on: November 27, 2016, 06:00:02 AM »

I would agree that this could be a battery or charger issue. Unfortunately I've had both a Pleo RB charger and a Pleo RB battery fail on me at some point, and I'm not sure which would be more likely in this case. When the charger failed for me, it was the power cord that died, not the cradle, but I believe that charger no longer lit up at all when a battery was placed on it. In your case, it could definitely be a dead battery if the Pleo hasn't been run in years though.
Pages: [1]   Go Up

SimplePortal 2.3.5 © 2008-2012, SimplePortal