Welcome, Guest. Please login or register.
Did you miss your activation email?

Username: Password:


Pages: [1]   Go Down

Author Topic: Drive_Example won't build. HELP!  (Read 2962 times)

seanstocktonclark

  • Hatchling
  • Posts: 2
  • Male
Drive_Example won't build. HELP!
« on: December 26, 2010, 06:46:39 AM »

drive_example is included in the PDK.  It is also the only example that uses commands. 

When I build it, I get the following error: "UnboundLocalError: local variable 'enum' referenced before assignment.

If I replace all "commands" with a single motion, it builds and run properly, so I am sure its related to the commands.  Has anyone else seen this?  Or can someone post a very simple command example to get me started? 

I am on OSX. 
Thanks

Sean
Logged


MannyNZ

  • Conifer Leaf gatherer
  • ** Posts: 21
  • Male
Re: Drive_Example won't build. HELP!
« Reply #1 on: December 30, 2010, 03:53:40 PM »

Hi,

well i can't tell much, from what you have posted so far. Are you using own enum variables?

So far i managed to write my own little drive-driven behaviours and they work more or less well :)
At least the command using part works ... the get pleo to avoid falling by making edge detection via those
user porperties combined with those leakers, wont work as much is i want them to yet.

So if you like you can post your source here or pm me, and i'll have a look through it, maybe i can find something.

what OS do you use to compile? ( just for interest ^^)

Manny
Logged
There are 10 types of people in this world. Those who understand binary and those who don't.
Pages: [1]   Go Up
 

SimplePortal 2.3.5 © 2008-2012, SimplePortal