Welcome, Guest. Please login or register.
Did you miss your activation email?

Username: Password:




Pages: [1]   Go Down

Author Topic: Flashing RB charger  (Read 278 times)

pickelish

  • Pleo wanderer
  • * Posts: 93
  • Female
Flashing RB charger
« on: October 08, 2018, 04:58:17 PM »

Hey! My Rb charger is flashing red. In the rb manual it says flashing red means the battery isn't sitting properly, but no matter how many times I try to take out the battery and put it in again it still flashes red.  He does charge fully, but it always flashes red. Also, I got my rb 2nd hand and there was no cord for the charger so I had to buy a strange one that I need to set to 9v. I tried to attach a picture but couldn't figure out how. Maybe it has something to do with the flashing problem? Is it possible to have a charger that flashes and will it still charge flashing red?
« Last Edit: October 08, 2018, 11:18:24 PM by pickelish »
Logged


mweed

  • Grand Poobah
  • Triassic pleo master
  • ***** Posts: 1720
  • us Male
  • Pleo(s): Bob, Mopey
  • : Tomat Harvest Festivals
    • Professor
    • Wile_E_Coyote
    • Dr_Bunsen_Honeydew
    • Snoopy
    • Bob the Pleo
Re: Flashing RB charger
« Reply #1 on: October 13, 2018, 09:18:31 PM »

The cord may not be providing the right voltage or enough amperage to properly charge the battery.  Can you post details about the transformer you are using?
Logged

Anya

  • Pleo wanderer
  • * Posts: 84
  • gb Female
Re: Flashing RB charger
« Reply #2 on: October 14, 2018, 01:35:43 AM »

Also if it helps I often see pleo charger wall plugs and cords on eBay on their own, you might be able to grab one and try it
Logged

Talon

  • Cretaceous pleo master
  • * Posts: 2640
  • us Female
  • Pleo(s): Ryu and Cato (Pleo RBs), Eugobe and Madam Bayou Bleu Le Chalet, (Ugobe Pleos)
    • Lucy
Re: Flashing RB charger
« Reply #3 on: October 14, 2018, 04:11:18 PM »

I can't tell where you are from, but sometimes voltage amounts are different in different countries. Maybe that might be your problem? Also, try cleaning both the contacts in the battery and those on the charger. Press on all three of those little knobby things where the battery touches and make sure they all are springing up straight. Oh and if there's a contact point in the center of the charger where the nub from the battery rests. Maybe that thing isn't clean or isn't springing up properly. Sorry. LOL! I've never taken a serious look at that spot before so I don't know if that could have anything to do with it.  Hopefully you'll find the answer to this mystery soon.
Talon
Logged
Pages: [1]   Go Up