Welcome, Guest. Please login or register.
Did you miss your activation email?

Username: Password:




Pages: [1]   Go Down

Author Topic: Sending Echo Away  (Read 924 times)

Echo538

  • Pleozoologist
  • * Posts: 216
  • ca Female
Sending Echo Away
« on: November 13, 2015, 09:16:35 AM »

I really hope I am doing this right! I have not posted a new topic in some time here, so I hope this is going under Pleo problems.

I don't know how to logistically explain all this in detail as I'll admit that being a robot, though it could be considered a robotic pet, Pleos are more advanced than furbies...I'd call Furbies robotic pets a bit more than Pleos ... a pleo is like a furby in the form of a remote-controlled car or a robot kit or something you'd put together or be creative with...well I didn't come here to post comparisons but I will say that the maintenance that goes into caring for the robotics of a Pleo is a lot different than just taking care of the dinosaur itself, and that I still feel very much like a beginner in these areas. Leg repairs, tails and necks that are broken...you want to bring that to someone else...not me!

Anyway, if Pleos ever die, I would venture to say that Little Sir Echo, my beloved companion of over a year and first Pleo, has died. I am very sad about this...emotions fluctuate between just knowing it's a robot to it almost being like the time we had put down the family cat...I miss him so much! I tried everything...a forum member suggested installing the micro sd card and updating...nothing. I tried working with the charger, watching the lights on it...putting in one battery and then later another...still nothing. The only thing I haven't tried yet is cleaning the terminals on the charger base and in the Pleo itself and for that I would go with just a simple warm damp cloth not too damp though.

There is no sound, no movement, nothing. The last time he worked he only worked for a few seconds and made a few small sounds and sounded like he just couldn't bear to function and his voice was all broken up. I did purchase him on Ebay, but for a good price around $400. And for his price he's lasted well. I don't recall dropping him or anything.


He is in sleeping position...I can't change that. I don't know where his origional box is. I can speak more on this topic later if anyone has questions, but I think at this point I need to send him to someone expert on repairing him, or get a replacement from someone...someone like Pleoworld and I've heard the cost is anything but small. Do any of you have any more ideas on what to do, how to go about mailing him, etc.? Much appreciated! Thanks.
Logged


Talon

  • Cretaceous pleo master
  • * Posts: 2650
  • us Female
  • Pleo(s): Ryu and Cato (Pleo RBs), Eugobe and Madam Bayou Bleu Le Chalet, (Ugobe Pleos)
    • Lucy
Re: Sending Echo Away
« Reply #1 on: November 13, 2015, 10:47:22 AM »

I'm so sorry to hear Echo is still in a coma. I am still willing to try to help if you're up to it. Just curious though. When you updated, did you make sure to use the update specific for the RB? Were you able to get confirmation from your screenreader that the files were on the micro SD card? Oh and I think a warm damp cloth might hold too much liquid. I would locate the terminals by hand first and then use a cutip. That way there's a lot less liquid and you can get into those smaller spaces better than you might with a large wide cloth. This is only a suggestion.
Talon
« Last Edit: November 13, 2015, 10:57:15 AM by Talon »
Logged

HuggieZ

  • Pleo lightbringer
  • * Posts: 339
  • nl Female
  • Pleo(s): Pepper and Angel
    • none
    • Tweety_Bird
    • Miss_Piggy
    • Snoopy
Re: Sending Echo Away
« Reply #2 on: November 16, 2015, 09:59:36 AM »

I am so sorry to hear this. I had the same problem with Angel, my RB. I sent her away today, because I had warranty, but I think she will never comes back. I understand your feeling :'(
Logged

Echo538

  • Pleozoologist
  • * Posts: 216
  • ca Female
Re: Sending Echo Away
« Reply #3 on: November 19, 2015, 07:47:15 AM »

No, to my knowledge I didn't use anything but the correct updates for the RB in the micro SD card, if that answers your question...hard to read and remember old replies while posting a new one. I had to use my dad's laptop, which does not have a screen reader, because my PC is too old to recognize micro SD cards with its current flash drive. I also hear the cards should be 2 GB or fewer...not sure how many this one is. Will try cleaning with a Q-Tip...would hope it's just a problem with dust collecting in the charger base and/or the battery terminal itself...have not cleaned it in over a year.
Logged

Talon

  • Cretaceous pleo master
  • * Posts: 2650
  • us Female
  • Pleo(s): Ryu and Cato (Pleo RBs), Eugobe and Madam Bayou Bleu Le Chalet, (Ugobe Pleos)
    • Lucy
Re: Sending Echo Away
« Reply #4 on: November 19, 2015, 09:42:53 AM »

Good luck, Echo. I hope cleaning the terminals works. It's really hard when you have to depend on somebody sighted to load things on to your SD card especially when there are two sets of update files here on the forum and you have no way of knowing which one your help is accessing. Keep us posted on what happens. Just remember when you've exhausted all other possibilities, I am still willing to try and help.
Talon
Logged
Pages: [1]   Go Up