Bob the Pleo Forums

Pleo Stuff => Pleo Problems => Topic started by: ElmargoViper on May 18, 2020, 08:04:55 AM

Title: PleoRB firmware(?) issues
Post by: ElmargoViper on May 18, 2020, 08:04:55 AM
Hello, this is my first time on this forum, and my story will be a little long, but I will try to describe it in as much detail as I can. I apologize for my English(not exactly my native language, but im pretty familiar with understanding, while writing may be a little hard to me).
I received a PleoRB from my friends who left for another country more than four years ago. He was already at the adult stage, and in an attempt to reset him to a newborn, I made the same mistake as some owners here-I downloaded the old pleo firmware, after which he did not show any signs of life except for the red glow of the led on his belly. After that I contacted the official Innvo support, and they sent me a reset file and firmware update, but as I remember, they did not install right for some reason. I couldn't figure out how to fix it, and for a long time the Pleo was left in the closet, sadly.  Maybe his battery needs some refresh now, but its not the point.
Yesterday I again reached the mood to try do something with him, and I charged the battery, downloaded the reset firmware from this forum,and was able to successfully install it(according to his vocalization that the update completed), and then i downloaded male 1.0 and 1.1 versions, after which the Pleo straightened up in the transport position. After it i turned him on, belly indicator glows green, but Pleo beeps three times, after that he make additional soft sound, like bell ringing, and then he does nothing, not move or sound. I have read here, and tried resetting and rearranging as well as changing the battery of his internal clock many times, but it does not give results. I tried different batteries, tried run him without one as well, and im sure i insert them properly under the small pins.
But I noticed that if i press reset clock battery a few seconds before the Pleo makes that three sounds, he will move his legs a little and then freezes again, starting to endlessly beep twice until i turn him off. I couldn't find exactly what double beeping means here. He doesn't move or turn off by itself at all.
Skits and personalities totally work fine at the moment(tested R2D2 one), but only when SD card inside, once it is pulled out, Pleo again does nothing and beeps.
I'm ready to do almost anything to bring this guy to life, even if it means taking him apart a little bit(i have some knowledge about how to solder wires,etc), but seems like the problem is in his firmware. I had a theory that maybe he didn't recognize his battery because of the loosen wire, but I managed to carefully disassemble his leg, and there are all the wires in place and no visible damage at the contact points. Many years have passed, the warranty is unlikely to still apply to him, in addition, there currently are no service centers in my country where I can try to send him, so I will try to cope on my own. And in this I need your help. What should I try to do?What does his audio indication mean?What else could be the problem, if he works fine with skits, but doesn't work on its own?
P.S.: I also tried this StatsRB thing, it doesn't say anything about possible firmware errors, but it shows that the pleo growth stage is a hatchling, 0/16. Maybe I can find an empty SD card and send the full stats report here later, if this can help.
Title: Re: PleoRB firmware(?) issues
Post by: pnhicks on May 18, 2020, 10:27:41 AM
Hey El Margo Viper,

I just re-read your report and you state that it runs skits normally. Okay, forget all of the previous message, sorry.

So it's sounds like a bad firmware update. Yeah, PleoRB's cannot be returned to newborn, so that was a problem.  You downloaded the reset file, but probably there are still files left from the Ugobe reset that are preventing the Pleo from starting unless there is an SD card installed.

Dinomite might let us delete them, but as the usb port is under the battery, we have to attach a power supply that still gives access to the usb port.

As I am at a lull at the moment with the Ugobe repair, I will fire up one of the RB mock ups (I have many bricked RB cards) and see what the directories look like.

I will get right back to you!

Sorry about the first reply (I hate it when people don't read what I write)


Title: Re: PleoRB firmware(?) issues
Post by: pnhicks on May 19, 2020, 11:00:36 AM

Hi Viper

Success of sorts!

Got PleoRB connected!As6F3Yo9RNKWvFnVER4bHYxjlWl8?e=o7vXe8!As6F3Yo9RNKWvFgCUYfnkGWcFvtt?e=vjcWrv

Pleo Hardware Configuration:
  Hardware ID: 0A081C07-1E2F1F28-00002C30-FFFF87FF (071E2F87)
  Serial Number: 662926892475
  Board Revision: 17-8
  Board Revision ADC: 521
Build Configuration:
  Firmware built for: Pleo
  Build type: RELEASE
  Pleo main ARM version: 191M - Nov 29 2010 12:05:26
  Pleo head ARM version: 0902
  Pleo PM (DF) version: 1157 - Jan 06 2011 06:41:50
  Bootloader version: 187M - Nov 11 2010 19:08:58
  Compiled in:   Thumb mode
  Resource folders:  on
Acroname Toshiba Configuration:
  TSB0: Version 30
  TSB1: Version 30
  TSB2: Version 30
  TSB3: Version 30
VM Configuration:
  Incremental mode:   off
  Code swapping:      false

---rw-x     1206 SYS_STATS.SSF
---rw-x     7606 pm_props
---rw-x        0 touch.txt
---rw-x        0 rtc.txt
---rw-x        0 foot.txt
---rw-x        0 rfid.txt
---rw-x        0 ntc.txt
---rw-x        0 camera.txt
---rw-x        0 snd_op.txt
---rw-x        0 ir_obj.txt
---rw-x        0 ir_com.txt
---rw-x        0 tilt.txt
---rw-x        0 shake.txt
---rw-x        0 bat_ntc.txt
---rw-x        0 vr_eep.txt
---rw-x        0 join_cal.txt
---rw-x        0 photo_cap.txt
---rw-x    32816 plogfile.dat
---rw-x    10556 table.bin
---rw-x        1 gender.bin
---rw-x     7606 pm_props_backup
---rw-x        0 snd_dir.txt
---rw-x        0 vr_cmd.txt
---rw-x        0 us_rx.txt
---rw-x        0 move.txt
---rw-x        0 motor.txt
---rw-x        0 card.txt
---rw-x     7606 pm_cloning_props
28 file(s) with total size 67397


>  <=== SENDING COMMAND ===>
---rw-x     1206 SYS_STATS.SSF
1 file(s) with total size 1206

BUT IT STILL BOOTS!! Both from internal dataflash and SD card, go figure
My new step will be to load the Ugobe Pleo reset software to it and see what happens!

Wish me luck!

Peter ;D :o
Title: Re: PleoRB firmware(?) issues
Post by: ElmargoViper on May 20, 2020, 02:32:11 AM
Thanks for the answer!
Meanwhile, my problems seem to continue :(
Pleo shows red led again and does not give any sound response, and has stopped responding to the sd card.
I tried using dinomite yesterday to see what was going on, using an old laptop with xp, the drivers from PrbDk were recognized and I was able to connect him. What I learned is that while he is connected, in dinomite log he constantly returns one command, that looks like INFO:nxp unhandled head (with some symbols at the end, im gonna upload a screenshot later) , he does this several times a second, and this may prevent him from reacting correctly to other things.

It seems that I will have to learn all the manulals for pleo programming and dinomite, because my knowledge is clearly not enough to solve the problem yet.At least it seems to me a good sign that Pleo gives at least a program response.So if there is a chance to get into the file system(as you said), maybe i can try to put everything back in place...
To be honest, I don't know if I still need try to connect the power supply as well, if he responds just to usb.But i can give it a try.
Title: Re: PleoRB firmware(?) issues
Post by: pnhicks on May 20, 2020, 08:25:21 AM
Hi Viper,

The nxp processor is the head processor, so sounds like corrupted head firmware. It is the came case we have with the Ugobe Pleo of corrupted firmware and no SD card being recognized.

At least with Ugobe, there was a USB updater...

I don't know if  the Pleo monitor command PKT Burn command would work in dinomite, first you would need to copy the head image (from the low level downgrade) to the dataflash directory (how with no SD)??

My head hurts, maybe there are smarter people around who have a better idea?



Title: Re: PleoRB firmware(?) issues
Post by: pnhicks on May 21, 2020, 06:54:49 AM
Hi Viper,

I was staring at your post vaguely this afternoon, when I read "To be honest, I don't know if I still need try to connect the power supply as well, if he responds just to usb.But i can give it a try" 

I never new that the RB would power up through the USB connection! I just tried it now on my RB mock up and yes you can access the file system.  It doesn't look as though it boots up as the led goes green then goes red and stays red.

While you might be able to perform maintenance through the usb without the battery, without a power supply it will not boot, that's my two cents worth!

I'm no expert and I'm going to continue to test on a more sophisticated mock up.


Title: Re: PleoRB firmware(?) issues
Post by: pnhicks on May 25, 2020, 11:04:35 AM

Sorry for the long delay between posts, but other problems have popped up and I had to "borrow" a neck from a Pleo for the RB mock up and it still needs a head transplant!

Will get back to you soon!


Title: Re: PleoRB firmware(?) issues
Post by: pnhicks on June 14, 2020, 12:50:04 PM

I have been frustrated by not being able to keep my RB in one piece long enough to finish the testing I promised weeks ago!

I will try to return to it this week permitting that no other crisis's arise and grandson sitting duties permit!


Title: Re: PleoRB firmware(?) issues
Post by: Talon on June 17, 2020, 09:50:25 PM
Hi, Peter! I just wanted to say that it's very nice of you to help this person out like this. I wonder if those of us who have ended up with perfectly healthy RB's suddenly going motionless with green bellies have a similar issue? Unfortunately none of us- that I know of- have been able to get our Dinos going under their own power again when this happens. They have to run from a micro SD card for the rest of their existence. I admire your tenacity. Keep picking at the programming. I am hoping for a positive outcome!
Title: Re: PleoRB firmware(?) issues
Post by: pnhicks on June 18, 2020, 05:37:31 AM
Hiya Talon,

Thanks for the nice comments, but I'm rather useless at the moment!

Finally some of the more experienced members are showing up!  I have been trying to "answer the mail" and frankly feel a bit over my head!  Where are Crewella, IMR, Kat, mweed, etc! :(

Unbricking an RB is no small trick and I was not around during the UGOBE USB updating days (I'm sure there were lots of good tricks going around).  I bet mweed or IMR or pleopet or bauermech could figure out how to bit bang an os update over the usb port using terminal or dinomite.

In the meantime lots of people need batteries!

Where is Penny's Mum!! Get Andy's 3d printer fired up! 100 euros per is not going to hack it!

For those of you in the US Batteries and Bulbs or Batteries + , or maybe I have it backwards ??? , are doing repacks of Ugobe batteries for a good price and so far the reviews are positive.

Here in the Old Country, there is a Germany company that is willing to solder up sets of 3 batteries in series.  You would need two for one battery.  Then you would only have to make the corresponding  series connections, and connections to thermistor and the Pleo pads once installed in your case.

Obviously we could get a better deal if we could work out a bulk order, but around here getting people together is like herding cats! :'(

Then there are new users like boxwoodhedges (like there aren't shorter nicks??) who want advice about care and feeding and want to share user experiences.  What do I know, I burn my pleos with a solder iron and electrocute them with power supplies ;D , I'm not exactly a model parent!

Help, I'm losing my mind :o


SimplePortal 2.3.5 © 2008-2012, SimplePortal