Bob the Pleo Forums

Pleo Stuff => Pleo Problems => Topic started by: aibo7m3 on May 10, 2018, 10:10:29 AM

Title: Semi-Bricked Pleo RB
Post by: aibo7m3 on May 10, 2018, 10:10:29 AM
Hi everyone! I purchased a semi-bricked Pleo RB from another user here a couple years ago and the Pleo has been set away in storage for a little while now, but I'd finally like to decide whether to sell or repair it myself since it's not much use to me just sitting on a shelf and would like to get some possible diagnostic info first.

When I received the Pleo:
The original owner told me that shortly after receiving the Pleo (which was new from Pleo World and a replacement for another broken RB), it suddenly stopped booting on random occasions and the problem got worse to the point where it would rarely start up at all. The Pleo RB was sold to me and it was "working" when I received it, but there were many problems apparent immediately. There was a loud buzzing sound behind the speaker and the speaker made frequent "popping" noises. The Pleo would only take food once per run time and afterward, the RFID reader became unresponsive, so the Pleo would constantly display hungry behavior, but could not eat. I believe the Pleo could not be turned off with the power button and I needed to pull the battery.

The Pleo worked for maybe an hour or so, and then stopped functioning. I tried many resets and replacing the clock battery to no avail. I later tried a firmware update which failed. I ran Probe RB on the Pleo and Probe RB was working at the time, but do not remember what report I received and the Pleo would not boot up when set on the ground. The skits that I tried did not work at all. After several days of resets/updates/etc, it started working again. When working, I could run skits in the Pleo, but they had the same speaker popping and buzzing noise present. Shortly after it stopped again and continued to work intermittently like this for a couple weeks before I put it away in storage.

What's happening now:
I pulled the Pleo out of storage today and put in a fresh battery. The power light turned green, but the Pleo did not respond in any way. I put in a micro SD card that I thought was Probe RB, but turned out to be a skit of some sort. The Pleo let out a groan while on its back and then went silent. I stood it rightside up and there was no response, so I flipped it over again, at which point it started running the skit (seemed to consist of a simple personality that liked blowing kisses and whistling a lot). I let it run the skit for around five minutes, and then tried shutting it off, but the power button was unresponsive. I pulled the battery and tried rebooting with no micro SD card and the Pleo started up, but as soon as it raised its head past the midpoint, it froze and went into some sort of error mode where it kept making soft sighing/breathing noises over and over without moving. At this point, I found my actual Probe RB micro SD card and tried it out. I tried it several times, but each time just got the message, "Welcome to Probe RB version 1.0, ready to report- Property load failed. Giving up." The Pleo seems to start up whenever I try booting it now, but freezes and goes into an error mode every time that it raises its head.

Here is a video of what happens:

Obviously there's something very wrong hardware-wise here, but does anyone have any clue what exactly might be going on? Is this something I could potentially repair at home or would it be better to just sell the Pleo to someone more experienced? I have a soldering iron and have performed simple repairs on Pleos before, but am not confident that I could skin an entire Pleo without damaging the skin itself or that I would be able to locate the issue if I did so. I am curious about looking at the neck wires since it seems to be freezing when it raises its head now and know how to pull back the neck skin without causing much damage to the seam, but I wanted a second opinion on this first as I may be selling the Pleo and don't want to cause unnecessary damage.

I would love to hear some feedback on this, as I'm very curious to get down to the bottom of what's wrong with this Pleo!
Title: Re: Semi-Bricked Pleo RB
Post by: aibo7m3 on May 10, 2018, 04:12:43 PM

I tried running her again and wiggled her neck slightly when she froze up. She then continued running and curled up, and I realized that she had somehow reset herself to a baby. I have no idea what caused this reset, but since it took place, Probe RB no longer recognizes her data and just gives the "property load failed" error. At the moment she is running and in hatchling stage, but her speaker is popping/buzzing and her RFID reader is not working.
Title: Re: Semi-Bricked Pleo RB
Post by: pnhicks on May 11, 2018, 02:20:41 AM
Hey Abio7m3,

As my father used to say, the great thing about working on broken things is you can't break them!
I say give it a shot; what have you got to lose?  Is there a warranty?  The neck seam should come apart fairly easily, just be patient and support both sides to prevent a tear.

Just my two cents (it does sound rather bad and I stand by to be corrected by the sages)


PD. Did I happen to mention that I have several RB heads rolling around? Just about any other body part as well in case that should prove useful. ;D
Title: Re: Semi-Bricked Pleo RB
Post by: aibo7m3 on February 08, 2019, 11:31:25 AM
I've been busy and haven't gotten a chance to open up Mimi yet, but I tried running Stats RB on her for the first time today, which gave me an odd report. Stats RB reported her as a Ugobe Pleo, rather than a Pleo RB. Probe RB gave the "property load failed" error again. This confused me, since she was never given a Ugobe update and Probe RB was able to report her data when I first received her some years back. In response to this, I decided to give her a high level RB update. In the past, this update has failed when I have tried to run it on her. Today, for reasons unknown to me, the update succeeded. Upon waking up from the update, she was in the hatchling stage with no run time logged. She now also shuts off when the power button is held down, which she was not doing before.

However, she definitely does have some sort of hardware issue, as her speaker is still full of very abnormal sounding pops and buzzes. I do not know why she reset to a hatchling either, as she was not a hatchling when I received her. It seems like all of her data was wiped, as Stats RB recognizes her as a Pleo RB, but all of her personality data has defaulted to "normal" and all of her current well-being stats have defaulted to 50%. She has not crashed again yet, but I presume she will as whatever hardware issue is going on is still there.
SimplePortal 2.3.5 © 2008-2012, SimplePortal